最近centos 5.3升級到5.4發生一些問題都會出現subversion的錯誤訊息,用google大神找了相關的資訊,發現原因了。

解決方法也很簡單就是把subversion 跟xdelta兩個程式一儲之後再重新yum upgrade就可以了。

原因如下

原文出處:Re: [CentOS] problem with centos 5.3 upgrade
http://www.opensubscriber.com/message/centos@centos.org/12491507.html

摘要如下:

The thing is that CentOS (and upstream) includes in the 64-bit
repository both 32-bit and 64-bit versions of the same package for
some packages that include libraries, as it is the case with the
subversion package. However, RPMforge has the policy of including only
the 64-bit version of packages in the 64-bit repository. That way,
when you try to update subversion, it will try to update the 64-bit
version to version 1.6 (from RPMforge), but it will have no way of
upgrading the 32-bit version that is already installed (32-bit RPM
from CentOS 64-bit repository), so that will generate a conflict.

As I believe you don't need subversion 32-bit installed and only the
64-bit version should be enough, I believe the easiest fix for you is:

創作者介紹

認真打雜好青年日誌

kennyp 發表在 痞客邦 PIXNET 留言(0) 人氣()