安裝很簡單,用yum就幾乎解決一大半的問題了,不過沒法子使用PECL安裝....怪怪的就是了,所以只好使用編譯的方式處理,是64bit的版本。

首先使用yum安裝

# yum install ImagicMagick-devel

因為之前的安裝沒有安裝php-devel所以無法使用phpize,也記得裝一下

# yum install php-devel

接著下載imagick-2.3.0.tgz

# wget http://pecl.php.net/get/imagick-2.3.0.tgz

# tar zxvf imagick-2.3.0.tgz

# cd imagick-2.3.0

# phpize

# ./configure

# make

# make install

這樣就裝好了

接著修改php.ini

# vim /etc/php.ini

在最後面加入

extension=imagick.so

重新啟動apache server

# /etc/init.d/httpd restart

參考自:酷學園網站的討論串

主題: [筆記,分享] ImageMagick for PHP 安裝(CentOS5, Ubuntu804)

創作者介紹

認真打雜好青年日誌

kennyp 發表在 痞客邦 PIXNET 留言(0) 人氣()